Jump to content
Sign in to follow this  
Jamjam

Jam RBS14 Crashed

Recommended Posts

good stuff. car should be ready for our next Primal MC day then :D

Share this post


Link to post
Share on other sites

good stuff. car should be ready for our next Primal MC day then :D

 

When when? I pay now!!!!

Share this post


Link to post
Share on other sites

Good to hear man. Atleast the motor isn't f**ked.

 

:)

 

Good news man :) things are starting to

Look up for you

 

Finally! Been missing out on too much fun.

 

you didnt remind me about those tensioners after work yesterday haha

 

Yeahhhh im hopeless hahaha.

 

f**k sounds like the shit I went through with the Stagea, bought brand new injectors only to find out they were f**ked lol. Sounds like you'll be apples though man.

 

I always say this when I post in your thread, but your car is amazing! kthnx.

 

Oh it's a nightmare Adam! So god damn frustrating.

Hahaha, you know that I'm gonna keep saying that about the stagea too? I want that thing so bad ;)

 

are the denso injectors fluro yellow in colour? just asking as i had to get an rb26 going last week that someone had fitted into a 32, along with these "new" denso injectors, long story short, after chasing wiring issues etc for a missfire found two of the injectors not working, bit of a tap while powering them up got them working, but it still misses randomly

 

That's exactly the injectors man! I dare say it must be a common thing with them... I think it was the same thing happened as they are all firing now.

 

Good to hear that the motor is fine ! Return of happy Jamie

 

Haha! I sure hope so Henry... Sulky Jamie sucks.

 

good stuff. car should be ready for our next Primal MC day then :D

 

This excites me :D

 

f**k yeah dude. keen to see the hard work pay off

 

Reality is.. I think this car just needs some Komen love.

 

SOOOOOO

 

Got the Injectors flow tested, they all came back perfectly fine and even. That made me confused. So slapped them back in, fire her up and boom running on all 6. I think like previously stated... They just needed a bit of help getting started.

 

But, the car was still running like absolute shit. The Rail, injectors and collars came as a package so I thought they should all work sweet together... But no. After hunting around, I discovered none of the collars were seating correctly on the bottom side (hard to see), so after using a piece of vac hose as a stethoscope, I discovered they all had MASSIVE VAC LEAKS. I feel so damn stupid for not realizing earlier.. But I'm putting it down to I couldn't hear them due to the car being so loud, and they due to being MAP sensored now it didn't cause the car to idle high, Just idle shit.

 

The collars themselves just didn't seat correctly and were the wrong size. And the o rings were also the wrong size and flimsy.

 

01FB719E-D9EF-41C8-B5D5-1E54D3611EDB-10447-00000A9B73F9FF0E_zps65f6b17a.jpg

 

So after pulling it all apart, trying to work out what to do... I was going to get some new collars spun up and some better/correct size o rings. Until I realized, the injectors fit PERFECT into the manifold with no collars/ o rings. Da hell? So pissed off all the collars, cut down the rail spacers and put back together.. And boom, running a million times better.

 

724D1B10-CB2C-4C7C-A622-0D082D05CED3-10447-00000A9B6B4B08C3_zps8330baed.jpg

 

So if might actually be ready for a second try at a tune soon. Stupid f**king china parts.

Edited by Jamjam

Share this post


Link to post
Share on other sites

China parts!

 

So you aren't running any o-rings? Won't they leak?

 

Found tensioners, they're NSK and something in that box for you

 

9DFEB7C2-1AE4-438E-AD9F-2EDE5001FDA3-7943-0000036F8AEEF970_zps1f474927.jpg

Share this post


Link to post
Share on other sites

China parts!

 

So you aren't running any o-rings? Won't they leak?

 

Found tensioners, they're NSK and something in that box for you

 

9DFEB7C2-1AE4-438E-AD9F-2EDE5001FDA3-7943-0000036F8AEEF970_zps1f474927.jpg

 

There's still O rings on the bottom of the injector man, they are like a step, and they fit perfectly snug into the manifold.

 

Ooooohh I like the sound of that box. I owe you some cashola.

Edited by Jamjam

Share this post


Link to post
Share on other sites

Stupid f**king china parts.

 

Yeh I had the same issue with the collars, solved by using some better sized orings and plenty of silicone spray.

Share this post


Link to post
Share on other sites

So when are we doing this water pump/cam belt stuff?

Oh and drinking beverages.

Share this post


Link to post
Share on other sites

good to hear its all going well for you now man!

Share this post


Link to post
Share on other sites

Wtf. That's crazy. Good to hear all is well. :D

Share this post


Link to post
Share on other sites

the day this thing and woods car is 100% is the day the world implouds due to awesomeness. haha

Share this post


Link to post
Share on other sites

Went for a roll.

 

29CE789F-0D82-4C46-887B-6127E1005707-417-0000002A45DE22DC_zps7d20175d.jpg

 

Slapped the new water pump in.

 

91D2EE56-6511-49C2-AF61-42CD98425AA0-417-00000027ABDDB512_zps740ea4ae.jpg

 

The bearing in the old one was fingered. Just need to bleed the cooling system and will be ready for round 2.

 

 

Share this post


Link to post
Share on other sites

If u want buy the stock large injector rubbers and they will fill that gap in the step up on the manifold. That's what I did with my setup.

Share this post


Link to post
Share on other sites

Looks so good sitting on the street : )! Hurry up and trailer it to my house kent

Share this post


Link to post
Share on other sites

the day this thing and woods car is 100% is the day the world implouds due to awesomeness. haha

 

A long time ago in a galaxy far far away

Share this post


Link to post
Share on other sites

9F4D11BF-F16E-4406-9F83-80F0956BBEFF-8371-000008C58429C8F9_zps6b671b80.jpg

 

Soooooo car got tuned today. Safe tune of 298rwkw at 18psi. Everything went good for one... miracle!

Except for the clutch slave blew up again. Seems its over extending and popping the guts out. So I'm guessing either the bearing carrier is too short or it's the wrong clutch ball pivot, but for now I'll just extend the rod.

 

It's stupid fast and stupid loud... Not sure about this loud on the street.....

 

Happy days :)

 

F658D972-A5FD-4CA0-BF01-4024E86BA08C-8371-000008C578D0E151_zpsc7a7c2f5.jpg

 

Share this post


Link to post
Share on other sites

f**k yes

Share this post


Link to post
Share on other sites

should be able to chirp 2nd now

 

better not park next to me again though

Share this post


Link to post
Share on other sites

Now just don't break it before you get a chance to bring it up here

Share this post


Link to post
Share on other sites

f**k yeah, plans for clear lenses like muscat? that would top it off

Share this post


Link to post
Share on other sites

That last pic is incredible.

 

Dead set best s14 man.

Glad this motor has at least lasted the tune haha.

Can I come passenger one day?

 

 

Share this post


Link to post
Share on other sites

 

f**k yeah, plans for clear lenses like muscat? that would top it off

 

Cant believe you didnt mention mirrors.

Share this post


Link to post
Share on other sites

do a burnout ya girls dick!!

This, I wanna see you cut hoops in the shed

Share this post


Link to post
Share on other sites

All that hard work has payed off man

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×