Jump to content
Sign in to follow this  
Jamjam

Jam RBS14 Crashed

Recommended Posts

Not doing anything wrong man, it's the luck of the draw with 20 year old second hand motors, look at my car lol

Share this post


Link to post
Share on other sites

Pull motor out and re-ring and bearings man. Is it from top end or bottom? Weird that its started knocking from just idling man.

Share this post


Link to post
Share on other sites

That really sucks man

rip the 25 give it a freshing up it new rings,bearings,oil/water pumps all new genuine parts/gaskets and you will be laughing :)

Share this post


Link to post
Share on other sites

Trent was worried about the china plenum leaking into the motor

 

But he also said just drop the sump and smash some bearings in instead of getting another 25

Share this post


Link to post
Share on other sites

I like the sound of that ^^*

And f**k off that plenum for a genuine one

Share this post


Link to post
Share on other sites

dude, just smash in a set of bearings!

 

stock plenum ftw! surely someone would buy yours and the cooler piping to suit

Edited by blingcommander

Share this post


Link to post
Share on other sites

You niggs are good at support, I appriciate it. Wanted to part it last night but I think I'll give it one more shot.

 

Yeah Trent thought there was a chance it could have been leaking water into the intake, although after he did some stuff he said there were no signs of it coming coming through although small amounts still could have. Could be causing it to not fire on cyl 2.

 

I don't have the first idea on how to do a set of bearings, but I can see it being worth a shot. Hopefully there's no damage to anything else.

 

First thing Trent suggested I put the stock injectors back in, stock ecu and plug in AFM and see if it's still missing on cyl 2. So I'll get that done.

 

2DA8D9F1-F0AA-415D-B069-18176753D40A-5832-00000637DD566F6C_zpsf1b9df27.jpg

 

573963E0-C75D-418F-8B26-3828F35638F5-5832-00000637D1B84187_zps33c90bd8.jpg

 

285FADF8-1C8C-4C86-988A-4BD4C9633C4A-5832-00000637E2BF7370_zpseb9acb67.jpg

 

ABC7C498-8F85-4724-A182-C37AA4E85149-5832-00000637D6E467D5_zps403b8db1.jpg

 

74BF0DE6-ADA1-4660-9524-007A16F6C965-5832-00000637BD844E4C_zps64fb263e.jpg

 

0ECDB2A2-02FA-48E5-969D-30723CBDFF3F-5832-00000637EAE1EB44_zps89d343d4.jpg

 

Share this post


Link to post
Share on other sites

Wow dude worst luck! I hate Microtech for these reasons. I've seen a few now with teething little issues.

 

Share this post


Link to post
Share on other sites

Bearings are alot easier to do than it sounds. Have done it. Just a prick getting at the nuts.

Edited by Bray!

Share this post


Link to post
Share on other sites

Yeah its easy man engine out and we will get it done.

Let me know when and we will come down.

New water pump and shit and then it should be reliable.

Share this post


Link to post
Share on other sites

So over pulling engines haha. Bad things come in 3s so the next one will probably explode too.

 

Cheers guys. I'll drink lots of beer and jd with you. Thanks josh, I think that will be the best bet.

 

This car is so gay.

Share this post


Link to post
Share on other sites

If you need any parts let me know mang! Special price for you.

 

Was looking so forward to see you driving again :(

Edited by muski

Share this post


Link to post
Share on other sites

Love this car so much!

 

When you driving next? Was so looking forward to seeing you out there again!

Share this post


Link to post
Share on other sites

You niggs are good at support, I appriciate it. Wanted to part it last night but I think I'll give it one more shot.

 

Yeah Trent thought there was a chance it could have been leaking water into the intake, although after he did some stuff he said there were no signs of it coming coming through although small amounts still could have. Could be causing it to not fire on cyl 2.

 

when you fitted the plenum did you check it agaisnt the gasket to make sure everything lined up? They can also leak internally because the casting is shitty. You can pressure test it on the car so might be worth doing to be sure. I have one on mine and it works fine but i had to do a f**k ton of die grinding to match the ports.

Share this post


Link to post
Share on other sites

If you need any parts let me know mang! Special price for you.

 

Was looking so forward to see you driving again :(

 

Thanks Musk, you're the best. Im motivated so soon :)

 

can i come live with you

 

Of course Jack, we can do lots of stuff that is fun and drink your favourite beer.

 

Love this car so much!

 

When you driving next? Was so looking forward to seeing you out there again!

 

Cheer Phil, Im not to sure really, just going to chip away at it.

 

 

 

Was good to catch up with you Henry!

 

Battery - When I first got the manifold I marked it with a new cometic gasket and port matched it with the dremel. I didnt check for internal leaks so thats defiantly something to look into.

 

UPDATE

 

So I put the stock injectors back in along with the stock ecu.. start it up and boom runs completely fine? Running on 6, no issues with cyl 2 at all. Which leads me to believe its either the microtech, or the brand new denso injectors / adapter plugs causing the issue.

 

But the other thing was.... no knocking? What the f**k? I only let it run for about 5 minutes so maybe it needed to get warmer to start knocking. So iv got no freaking idea whats going on. Any ideas from you gurus?

Share this post


Link to post
Share on other sites

When I first put my microtech in (with the patch loom) it only ran on 4cyl lol, but just needed to tighten the f**k out of the connector bolt that holds the factory loom and it ran all sweet.

My tuner said its a common prob with these and make sure if I undo it to do it up stupid tight or I will have wiring issues. ;)

 

Hopefully knock is nothing, but you may have to get a bit of load on the engine to get it to knock.

 

 

Share this post


Link to post
Share on other sites

Should totally smash standar turbo/manifold back on and come skid Calder still

Share this post


Link to post
Share on other sites

Should totally smash standar turbo/manifold back on and come skid Calder still

 

like

Share this post


Link to post
Share on other sites

ditch the microtech and go with a nisstune dude?

 

just dont give up on it yet, we still havent skidded together properly yet!

Share this post


Link to post
Share on other sites

When my sr was knocking it was still knocking when cold everyday for 2 weeks lol.

 

I hope there's no knock

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×