Jump to content
Sign in to follow this  
SIR ASHMAN

S13 Instrument Cluster

Recommended Posts

Thought I could also add (but most prob know) that if your handbrake light stays lit once you put the handbrake down it is an indication that the brake fluid is low... That is for non-abs equipped cluster (well that's what mine is anyway... :lol:)

 

Has happened to me a couple of times and I topped the fluid up... turned out I needed a seal kit for my rear calipers cause they where leaking brake fluid, hence why it was low and leaving the handbrake light on...

Share this post


Link to post
Share on other sites

my fuel light comes on at a bit more than 10L... there's at least 15L in there when it comes on i think

Share this post


Link to post
Share on other sites

So is there an engine light at all on the cluster. On my 95 180 i have the airbag cluster, the 2nd icon stays on all the time. I thought it was an engine light and something was wrong but according to this it's a catalytic converter light. Does this mean that the reason why it's always on is because there is nothing connected to my cat???

Share this post


Link to post
Share on other sites

hey do u know about CA Cluster ABS and S15cluster

Share this post


Link to post
Share on other sites

Ashman, i took my ca18 cluster out last night to wire up the resistor so my tacho will work (ca18 to sr20det conversion).

 

I found some type of box thing on the back of the cluster with a cut wire to "batt" and the other wire went to "buzzer" i assumed it was for the chimer so i removed it from the back of ther cluster as it didnt seem to be in use anyway.

 

Can you tell me what this box is/might be? Since removing it my clock doenst work ? haha. Backlighting comes on but no TIME. Any ideas?

 

Thanks dude.

Share this post


Link to post
Share on other sites

hey my mate has the problem with the car converter he was wondering how much is a new one for non turbo sr20de

cheers

Share this post


Link to post
Share on other sites

would having a bored out cat make the cat overheat light to come on??

i think mine has one its 3" mandrel bent

Share this post


Link to post
Share on other sites

The Type X clusters do have an engine check light:

check.jpg

 

But if your looks like a small rectangle with heat lines coming off it then that is the cat converter light. Yes it could be because the sensor is not connected, if the sensor earths out it will usually set the light off - just tape the probe/wires up with tape and it should go off.

 

I know it's late but i fixed the cat converter light. Since i couldn't find the wire under the car i just cut the wire from the ecu and it worked.

 

Ecu pin out 26 - Exhaust temp sensor input - Blue Yellow.

 

Just wrote this up incase someone else is having the same probs.

Share this post


Link to post
Share on other sites

Anyone know the wires for the tacho? Mine stopped working and want to check signals before replacing the cluster.

Share this post


Link to post
Share on other sites

Pictures not working.

 

It would be uber useful to have them working... just saying.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×