Jump to content
Sign in to follow this  
Cootha

S15 Aircon fan control issues

Recommended Posts

So, my ac fan will only switch on then I set the fan speed to 4 (max speed). The compressor works and you can hear it engage when you click the ac on to fan speed one but there is no air blown out on setting 1-3 only on setting 4 do you get the fan working. The air is cold like it should be but will only blow on the maximum setting? Should i just get another ac control unit and hope this fixes the problem or is it likely thats it more complicated then that?

Share this post


Link to post
Share on other sites

Fan speed resistor is f**ked, get a new one.

Share this post


Link to post
Share on other sites

Is that part of the control unit assembly?

Edit, I found it on taarks. I'l buy a new one in and hopefully it works, thanks Protius.

Edited by Cootha

Share this post


Link to post
Share on other sites

So I though this might be a common issue and that this might help people if there unsure how to replace their own. I couldn't find any photos of its location except this one on taarks ytxubqF.jpg

The fuse is located under the blower motor in the passengers footwell, its held in place by two screws.

Remove these to pull it out 4Z7S3yl.jpg

 

This is what it looks like 1xjqMH2.jpg

 

This was mine, its in poor condition with obvious corrosion. I checked each pin in the connector with a multimeter to make sure each setting (1-3) works. It seems that the resistor is broken, il ordering a new one and will report if this fixes the problem.

Edited by Cootha

Share this post


Link to post
Share on other sites

I used to worked on car A/C daily and this sort of problem is VERY common on just about any car :) Hence my original short but sweet post haha

Share this post


Link to post
Share on other sites

I got my new fan speed resistor and it all works perfectly now :) unfortunately I also had a pretty big frontal collision when someone did an illegal right turn in front of me. So i ended up with a car with great Aircon but no front end haha.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×