Jump to content

-RPS13-

Silver Member
  • Content count

    310
  • Joined

  • Last visited

Community Reputation

0 Neutral

About -RPS13-

  • Rank
    Silver Member

General Info

  • Location
    Australia NSW
  • Gender
    Male
  • Car Type
    Nissan Silvia
  • Car Model
    5/97 RPS13
  1. 2013 Formula 1 Discussion Topic

    What a race!! Definitely the best one of the season - Mark Webber is a gun, he would have enjoyed his last British Gran Prix...
  2. Probably very obvious but you will get f%&ked for not having one or having it not connected during an EPA inspection...
  3. I also found the lines useless aswell, but because I bought non SR20 specific...think I also massaged the hang on my engine mount too, I've got the 3' front cover...
  4. JJR cat backs

    are the above & gktech & the ones on ebay all the same system, they look so similar??
  5. emissions notice need some help

    Have you got the notice in the mail yet?? it sounds like a head f$&k but with the factory Nissan cat back exhaust, airbox and all factory air intake you will be fine, I was shitting myself when I got one of these - mine was noise & anti tampering... make sure all hoses from turbo and wastegate are connected nothing to atmosphere, factory rubber intake from compressor cover to airbox, connect plug for AFM if still in engine bay, remove and block BOV fit factory diameter exhaust with factory mufflers, if its only noise and anti tampering you will breeze through, go to tuner and make sure check engine light appears when ignition is turned, you may fail for that depending where you have the inspection...
  6. S14 legal on NSW roads?

    School holidays...
  7. or go to motorsport connections like i did...no dramas at all...
  8. Any issues you could report with the turbo mate?? Good work, are you going to drive it on the street on that boost??
  9. intake & throttle body cleaning

    How come that car has no import plates on the firewall?? if the turbo sounds normal during normal operation I wouldn't fiddle or concern yourself with shaft play...
  10. correct, same front cover, i have the internal wastegate item though...
  11. Give them another call. Do you think I honestly came on here twice in one day and then again the next at 6:30 in the morning to post that,
  12. I would suggest definitely talking to Turbosmart, GCG and or your the tuner about this issue, It seems its related to a rich tune, do so before pulling turbo off again I reckon...
  13. I would suggest definitely talking to Turbosmart, GCG and or your the tuner about this issue, It seems its related to a rich tune, do so before pulling turbo off again I reckon... I would suggest definitely talking to Turbosmart, GCG and or your the tuner about this issue, It seems its related to a rich tune, do so before pulling turbo off again I reckon...
  14. I would suggest definitely talking to Turbosmart, GCG and or your the tuner about this issue, It seems its related to a rich tune, do so before pulling turbo off again I reckon...
  15. It sounds like it, unfortunately its the worse type, I had similar issue with my TD06 SR combo and found an easy fix was to adjust the Gain setting on my elec boost controller. I am of understanding that it is a tuning issue, but am not a tuner and don't know what the method is to eliminate it, I will be looking forward to other responses and how it can be eradicated... i struggle to understand that it can be a common issue when there are so many people using the TD06 on so many different applications...
×