Warning: Illegal string offset 'html' in /home/nissansi/public_html/forums/cache/skin_cache/cacheid_1/skin_topic.php on line 907
Left headlight low and hi beam not working ,15a fuse blows, aftermarket HID - Hardtuned.net

Jump to content


Left headlight low and hi beam not working ,15a fuse blows, aftermarket HID 

hid s15 headlight
4 replies to this topic

#1 180 wanabe

  • Joined:05-December 02
  • Location:Australia QLD
  • Car:S15

Posted 09 May 2017 - 05:08 PM

Hi guys

I noticed last night that my left headlight was not working.


The previous owner had done a HID conversion which was working fine until last night.

I checked the fuse box in the engine bay and noticed that the 15A blue fuse for the left-hand headlight had blown.

I replaced the fuse with a new 15A one and went to turn on the headlights and had the same issue with only the right side working. The newly installed 15A fuse had also blown.

So I'm just wondering if it's more than likely the case that the HID ballast on the left side is causing the fuse to blow?

Any input would be great. Fro what I can tell the HID ballasts seem to be wired directly to the battery

#2 Scotties15

  • Joined:08-May 05
  • Location:Australia QLD
  • Car:S15 200sx

Posted 09 May 2017 - 07:32 PM

when i had HID's i had them wired into the stock loom... with connection plugs.... worked fine.

check earthing.
check for worn wires that are shoring out...

#3 chris_c30

  • Joined:29-December 12
  • Location:Australia SA
  • Car:s14a 200sx

Posted 10 May 2017 - 06:49 AM

Unplug the balast and see if it still blows, also if you end up looking for a short somewhere get a resetable fuse makes life allot easier

#4 Dose Pipe Sutututu

  • Joined:19-January 05
  • Location:Australia NSW
  • Car:Boat Sutututuutu

Posted 15 May 2017 - 12:10 PM

I would run a separate power feed to three HID setup. Some have huge current demands on initial startup.

Battery -> fuse -> wiring-> HID

#5 andhey

  • Joined:10-January 11
  • Location:Australia VIC

Posted 15 May 2017 - 10:25 PM

Check your drivers side loom too





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

Common Links

  • About Us
  • Privacy Policy
  • User Agreement
  • Help & Support Forums
  • Advertise
  •  

    By your continued use of this site, you agree to follow all Rules & Guidelines and abide by the User Agreement outlined in our Terms & Conditions.

    Hardtuned Network is hosted by Sanity Technology

    Design, Site Management & Hotness provided by Loz.

    Big thanks to all our members and volunteers for making this network what it is today!